Рейтинг@Mail.ru
Сети
Настраиваем inter-VLAN Routing на маршрутизаторе Cisco
anton
09-02-2020 20:50
3 мин на чтение
42
0

В этой статье мы рассмотрим как настроить маршрутизацию внутри VLAN на оборудовании Cisco. Тестовую схему мы создали с использованием симулятора Cisco Packet Tracer.

Предварительно настроили все IP-интерфейсы на хостах. Важно каждую все хосты делить на категории и присваивать им соответствующий VLAN. Каждая группа находится в своей подсети и имеет свой собственный шлюз по-умолчанию. Шлюз по-умолчанию мы настроим на маршрутизаторе посредством создания сабинтерфейсов.

Начнем с того, что настроим порты на коммутаторе:

Switch(config)#vlan 2
Switch(config-vlan)#name admin
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#name user
Switch(config-vlan)#exit
Switch(config)#vlan 4
Switch(config-vlan)#name server
Switch(config-vlan)#exit
Switch(config)#interface fa0/1
Switch(config-if)#description admin-PC
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#interface range fa0/2-3
Switch(config-if-range)#description user-PC
Switch(config-if-range)#switchport mode access 
Switch(config-if-range)#switchport access vlan 3
Switch(config-if-range)#exit
Switch(config)#interface fa0/4
Switch(config-if)#description server
Switch(config-if)#switchport mode access 
Switch(config-if)#switchport access vlan 4
Switch(config-if)#exit
Switch(config)#interface fa0/24
Switch(config-if)#description Router
Switch(config-if)#switchport mode trunk 
Switch(config-if)#switchport trunk allowed vlan 2-4
Switch(config-if)#exit
Switch(config)#

На свиче мы настроили порты доступа (access) в сторону ноутбука админа, компьютеров и сервера. Когда кадр попадает на этот порт он маркируется соответствующим VLAN. Также мы настроили транковый порт (trunk) в сторону роутера. Это своеобразная “труба” через которую проходят кадры только определенных VLAN. В нашем случае VLAN 2,3,4.

Если сейчас попробовать, например, с компьютера админа пропинговать сервер, то ничего не получится.

Мы находимся в разных VLAN и подсетях, поэтому пинг не проходит. Чтобы получить доступ к серверу, необходимо, чтобы какое-то устройство “увидело” в какой VLAN находится сервер и перенаправило пакет именно ему, присвоив соответствующий VLAN. В нашей схеме данную функцию выполняет маршрутизатор. Мы настроим сабинтерфейсы (виртуальные интерфейсы) в качестве шлюза по-умолчанию для каждого VLAN. Когда админ пытается пропинговать сервер, то его ноутбук пошлет пакет на шлюз по-умолчанию (172.16.0.1 – VLAN 2) с адресом назначения 172.16.2.5 (адрес сервера). Маршрутизатор увидит, что подсеть 172.16.2.0/24 находится в VLAN 4 и отправит пакет на сервер.

Итак, настраиваем маршрутизатор.

Router(config)#interface fa0/0
Router(config-if)#description Switch
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fa0/0.2
Router(config-subif)#description admin
Router(config-subif)#encapsulation dot1q 2
Router(config-subif)#ip address 172.16.0.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fa0/0.3
Router(config-subif)#description user
Router(config-subif)#encapsulation dot1q 3
Router(config-subif)#ip address 172.16.1.1 255.255.255.0
Router(config-subif)#exit
Router(config)#interface fa0/0.4
Router(config-subif)#description server
Router(config-subif)#ip address 172.16.2.1 255.255.255.0
Router(config-subif)#encapsulation dot1q 4
Router(config-subif)#exit

Первым делом мы физически включаем интерфейс в сторону свича (при этом настроек IP не делаем). Далее создаем три сабинтерфейса и помечаем и соответствующими метками VLAN и IP-адресами шлюзов. Проверяем ping с компа админа до сервера – он идет:

Таким образом, мы настроили маршрутизацию внутри VLAN на оборудовании Cisco.